new input system not responding to keybinds

I’m trying to write a new movement script for my game with the new input, but the key binds aren’t responding. I followed some tutorials to make a basic movement script with the new input system and made key binds for keyboard and controller. I had the script just print a Debug.Log to test the inputs but when I run the project nothing prints when I press the keys. I tried printing debug message on start to check that Debug.Log was working and it printed. So then I tried using the new version of GetKeyDown, I just wrote a couple of lines that printed a Vector2 when wasd was pressed and it works, but the regular keybinds still aren’t working. Does anyone have any clue how to fix this?

@RubberSoulMan06 could u send the code so we can see what u did

Are you using SendMessage? Bec it doesn’t work for me either, it won’t even Debug.log() in Update.

I have the same issue.

I followed the exact setup from Brackeys: CONTROLLER INPUT in Unity! - YouTube

And just bound some Debug.Logs to the controls, but I get not action triggered whatsoever. Tried on both Unity 2019.3.0f3 and 2020.1.6f1. On inspection of the Input Debug window, I see all actions are enabled, but nothing happens.

private void Awake() {
        // refs
        m_Character = GetComponent<TPC>();
        m_PV = GetComponent<PhotonView>();
        m_Controls = new PlayerControls();
        m_Cam = Camera.main.transform;

        Debug.Log("Bind input actions to handlers");

        // bind controls
        m_Controls.Character.Jump.performed += ctx => Debug.Log("Jump"); // m_Jump = true;
        m_Controls.Character.Crouch.started += ctx => m_Crouch = true;
        m_Controls.Character.Crouch.performed += ctx => m_Crouch = false;
        m_Controls.Character.AnimationCancel.performed += ctx => m_Character.CancelAnimation();
        m_Controls.Character.PrimaryAttack.performed += ctx => m_Character.Attack(AttackType.Primary);
        m_Controls.Character.SecondaryAttack.performed += ctx => m_Character.Attack(AttackType.Secondary);
        m_Controls.Character.Move.performed += Move;
    }

    private void OnEnable() {
        Debug.Log("Activate controls");
        m_Controls.Character.Enable();
    }

    private void OnDisable() {
        m_Controls.Character.Disable();
    }    

Input setup:

I was in the same position as you uninstalled System Input, closed Unity. Reinstalled System Input, reset Unity, started NewMovement.cs script from zero. AND dont forget to include the enable and disable on Awake(). That got mine working… good luck!

I have the same issue plz can someone tell how to solve it bcz of this my game’s development is delayed for more than four days