New Input System - Problem with USB Controller

Hello everyone!

I am running on Unity 2020.3.0f1 and using the new input system on version 1.0.2.

I am trying to connect my USB controller, but Unity do not seems to get any inputs in game. The controller works fine in Windows → Control Panel → Devices → Game Controller Settings and My XboxOne Controller has no problem in Unity

When looking in the in the input debugger, I can see the controllers and in its debug window I can see events happening even without me holding the controller.
177583-controleranalysis.gif

What I’ve tried :

  • Rebooting PC

  • Closing Steam and all other apps

  • Plugin in different USB ports

I’ll try to have my friend try it on its PC, but as mentioned above, it works fine in Windows’ built-in controller config.

Any ideas?

UPDATE :

I have found that my gamepad is detected as a Joystick. Is there anyway to tell unity that it is a gamepad and not a Joystick?

it worked with me when i used a different control scheme than keyboard scheme.
add a new control scheme call it Gamepad and assign gamepad actions to it.
in player input component put value (Any) in control scheme or put Gamepad.

Same problem here, has anyone found a solution? I am using a noname usb controller

Same issue here, just started recently.
Controller is read fine by Windows, and works on occasion with Unity, but often it stops working.

I checked in the input manager and set it to listen, unity doen’t even pickup input,

I am using joy-cons with better joy the controller works in listen mode but it doesn’t in play mode

Same problem here Xbox One PDP controller, Unity sometimes perfectly detects and sometimes it refuses to and I have to restart it. Unity 2020 LTS