New User - after opening Angry Bots and Bootcamp demo nothing shows up in IDE

Perhaps I am missing something here. In an effort to follow along with the documentation (and later some tutorials) I downloded the bootcamp demo and opened it in the Unity IDE. The assets showed up in the bottom left pane but the top center window was grey with nothing in it. I tried building the game and it ran fine as a stand alone .exe. I also tried this with the angrybots demo with the same results. I do see some warning messages at the bottom regarding shaders.

Sort of stuck here. Any help on how to proceed would be appreciated. Thanks.

Try selecting an object in the Hierarchy, then moving your mouse over the scene view and pressing ‘F’ to focus on that object. It’s possible your camera is just way off somewhere and not seeing anything in the scene.

Ah ha! I think I’ve got it!

Try this:
Open up AngryBots, look in the Projects pane, click “Assets”, then doubleclick the “AngryBots” icon. It looks like a 3-d cube, same as the Unity icon. When I do this, the both the Scene pane and the Heirarchy pane are filled with exactly the stuff I expected to see.

I think what happens is the following:
Each Unity project has a number of “Scenes” which are like game levels. For most projects, when you open them up, Unity reads in the assets, and opens up one of the scenes. Oddly, for AngryBots, this isn’t true. When you open this project, Unity loads the assets, but doesn’t load any of the scenes. So you have all the parts, but the scene view is blank, because you aren’t looking at a scene. This, then, is easily fixed by opening a scene, by double-clicking any one of the scene-type Assets.

TimBur, I think you have it! Thank you very much. I tried that with the Bootcamp demo and it worked exactly as you said. I had been working through the tutorials in a Unity book (Unity 3.x Game Development) so I hadn’t looked at this again. Imagine my dismay when I tried to open something I had created and it wasn’t there! LOL. thanks again.