New! VR Beginner: Escape Room

5516323--566350--witchHouse_screen_05 (1).jpg

We're really excited to introduce our latest project for Unity Learn - a Beginner VR Escape Room experience. Explore the environment and learn about the basic VR interactions to apply them to the prototyping scene. Follow the tutorials alongside the project in editor to get the most out of this free project.

This project is compatible with Oculus Rift, Rift S, Quest and HTC Vive - please have your headset setup before downloading and beginning this project.


Let us know what you think and as always, we are so grateful for your feedback on our work!

Grab the project on the Asset Store
Follow the tutorials on Unity Learn

Thanks :)

9 Likes

looks really great. I will dive-in this weekend!

2 Likes

I have not been able to get this to build correctly on Quest for the life of me. I get a black box in my dashboard, almost like playing a video, the game doesn't render at all.

Also, the steps in the written tutorial are not clear, as the project does not appear in the learn tab of unity hub. Instead, I had to make a new project first, then go into package manager and import from there. Maybe this was my issue?

I think this is a great package, looks fantastic, and I can't wait to start going through the XR toolkit with my students!.. If only I could get the project to build!

1 Like

Hey vpinto,

Thanks for taking an interest in the VR Project, and sorry to hear about your issues!

As this project is soft-launched for now it hasn't appeared in the Learn tab of Unity Hub - it will be there as soon as the release is publicly announced rather than just on the forum.

As for the Quest build we have been updating the instructions for building over the last two days - maybe give them another look? It sounds like you're able to get the project to build correctly but not to display correctly? Did you set your Graphics API to Vulkan specifically for Android builds? Also make sure your Texture Compression is set to ETC2 (GLES 3.0) in the Build Settings.

Hey! Just as an update we also ran into this issue later during the day today. It seems that manually uninstalling any pre-existing Unity builds from the Quest device (you can do this by navigating to Settings > Storage > Unknown Devices and selecting the applications you want to uninstall).
After doing so we were able to build an executable that was running correctly. Please do let me know if this fixed things for you!

I have tried absolutely every thing that you have suggested, followed the updated instructions to a tee, and still having the same issue.

I'm assuming I just need to remove the pre-existing build of the same project, as I have a few others on there (which by the way fully function using srp,opengl, and OVR).

Everything else is set exactly as you mentioned, and I am still getting the same black screen

Ok. I ended up changing to multipass instead of multiview, and it magically worked.. though when i went back into unity the oculus tab of the XR plugin management has changed into the older version where it just lets you choose stereo rendering and V2 signing. There were several more options beforehand..

I literally have no idea what I did to get it working, but it finally builds properly and I could explore the two premade scenes!

thank you for the help and for making this amazing project for learning!

Congratulations on getting it working and thanks for posting your steps on the forum! We tried all the possible texture compressions with the Oculus Stereo Rendering set to Multi Pass and it worked everytime so we've updated the instructions. It seems the installations vary depending on the exact order you perform them in which might explain the different Oculus settings you were seeing.

Thanks for your interest and your kind words! We hope you and your students enjoy the dive into VR! :)

Hello !

I just downloaded the project and everything seems to work fine with an HTC Vive

But I got something i find weird in the prototype scene, I don't have any component attached to the toaster, it's not grabbable, the knob cannot be turned and the lever cannot be pulled is that on purpose or something is missing ?
The left thermostat has the same "issue"

Anyway thanks for your work it's appreciated ! :)

We decided to include some extra prefabs/objects without interactions so that users could try creating there own however it seems we left a couple in the scene rather than just in the prefabs folder! Thanks for letting us know, we will get this sorted in our next update.

Thanks for the positive feedback, enjoy!

2 Likes

Hello,

In my quest apk is not running and it is opening like a black dashboard screen and nothing is rendering at all.
my graphics library is Vulcan and Texture compression is ETC2, and there is pretty much storage left in my quest.

Please help me!!

1 Like

Hey!

Sorry to hear you're having problems getting the project to run on the quest. Have you set Stereo Rendering to Multipass in the Oculus settings within XR Plugin Management?
Sometimes re-building on top of an old build fixes the issue. Try switching texture compression back to ETC (default) and selecting Build and Run again. If the switch doesn't work, try deleting the old build from the Quest and then building again. Good luck and let me know if that worked!

After exploring the project a bit more, I've realized that the post processing is not working when built for Quest. Does this have something to do with URP? Vulkan? Do I have to make sure I'm using a particular URP (mobile vs desktop)

I have been trying to figure out how to have performant bloom on Quest, and it seems like this project is using the most current frameworks, so I am just a loss.

In URP there is a checkbox on your camera (in this case our camera is on the XR Rig prefab) which needs to be ticked in order for post-processing to work. Because we wanted to get as much performance out of the Quest version as we could we decided to turn this off, this is likely the reason you are having trouble getting PP working. Hope this helps!

5533261--568618--upload_2020-2-28_15-19-19.png

5533261--568618--upload_2020-2-28_15-19-19.png

Yes, I do have that checked, tested both in the escape room scene and a new "prototype" scene with added pp volume. N o effects are rendered.

Also, when I rebuilt in the escape room scene after turning post processing on, the teleportation assets dissappeared on.. for some reason they now become disabled on play.

Edit: This of course is happening because I didnt put the book on the pedastle to enable them!

So what did I do, I decided to start again, so I can understand the steps to get this project running. What happened? I ended up back where I started with the black box, even after doing everything that has been mentioned so far.

As I mentioned earlier, I noticed a difference in the oculus tab of the XR plugin management, or rather that it had changed. I have attached screenshots of both. I only managed to get this rendering correctly on device with the panel that has fewer options.

5533708--568786--2020-02-28.png
5533708--568789--2020-02-28 (1).jpg

Hello everyone and thank you very much for this!

I'm trying to understand what is the best way to prototype VR projects quickly and I have been overwhelmed by VRTK, steam vr, oculus interation .. and all the problems they have with each other!

a week studies vrtk3, but then the 4 is better, but then the 4 does not go with steamvr and if the user has oculus?!?

no, you can't do that!

It seems to me that this is the solution!

I followed the whole tutorial and found it really well done.
If I can afford a note, I would have liked to have a little more explanations on the parts to interact with: like the buttons, the clock / menu on the right hand, and some explanations on programming .. for example what could be the best method for open a door? by clicking a button?
pushing it?

Another important point I think may be what to study next ..
the Design, Develop, and Deploy for VR course goes deeper, but uses different technologies .. is there a way to use those techniques (vrtk) with Unity XR?

Thanks again
great material!

I changed to android build (for Quest) and followed every step as shown in the tutorial. The build takes extremly long in the "compling shader variants" step, is this normal? I don't have a "high end" PC (only a VR ready PC with a GTX 970 and i5 6500 3.20GHz), but it still weird that such a simple scene (graphical wise) takes so long to build (Im currently at 30min and the part is like 40% done)

Also the Quest build seems a little "laggy" it's playable, but sometimes frame drops are noticable. Maybe the tutorial could add some additional optimization tricks for the Quest version?

Otherwise it's a nice demo, good job!

hey folks,

tried importing with 2019.3.3, keeps failing decompressing package :'(

Failed to import package with error: Couldn't decompress package
UnityEditor.Web.JSProxyMgr:smile:oTasks()


I did this just yesterday in 2019.3.3 on a Mac and didn't run in to any issues. So, I'd suggest clearing your cache and re-downloading from scratch.

I also get black dashboard on Oculus Quest and nothing more. Has anyone found a solution? I've tried everything that have come to my mind.