NGUI UI Not Visible In Scene View

Good afternoon,

I am using a MacBook Pro with Unity 3.4.2f3.

When I create an NGUI UI, I cannot see it in Scene View. It is visible in Game view but not in Scene view. Also, in existing projects, using NGUI leads to the scene and the UI being rendered twice in existing projects when I press the play button.

What should I do to solve these issues?


in the Hierarchy View the UIroot(standardname “UI Root (2D)” object has attached a Camera (standardname “Camera”) doubleclick that Camera, the Scene View should be zoomed onto the
Ngui objects.

I just ran into the same issue - none of my NGUI objects appeared in the scene view. Turned out the NGUI layer wasn’t active for me - that was the reason. So make sure to have the layer you have your NGUI objects on active in the layers setting (next to where you can manage your layouts).

See also: Toolbar in Section “Learning the Interface”, Unity Manual

it’s the clipping mode in your camera :slight_smile: ihad the same issue a while ago

Make sure the ‘UI’ layer is visible in the ‘Layers’ drop down at the top right of the Unity editor. Right above the default location of the inspector.

If the UI is being rendered twice you have more than one camera in the scene with ‘UI’ active on the culling mask property.