No colliders on trees?

Hi, I’m currently working on a horror game, I’ve placed a bunch of trees but when I use my First Person Controller, I can walk across them… It’s so weird.

If you guys have a good idea, please post them below! :smiley:



I did a video on this. Jump to 4mins 40secs : 09 _ Terrain 1-2 : Trees and Grass - YouTube

If you have already placed your trees, it’s not all bad!

  • In a blank scene, drag in your tree.
  • Add a Capsule Collider to the tree
  • scale the collider to the correct size
  • now save that tree as a new prefab
  • go back to your terrain, in the terrain inspector, in the trees tab, swap the tree without a collider for the tree you just made

Edit : D’oh, too slow again =]

From the official Unity documentation:

If you’d like your trees to make use of colliders, it’s very easy. When you’ve imported your Tree asset file, all you need to do is instantiate it in the Scene View, add a Capsule Collider and tweak it, and make the GameObject into a new Prefab. Then when you’re adding trees to your Terrain, you add the tree Prefab with the Capsule Collider attached. You can only use Capsule Colliders when adding collisions with trees.

(Scroll down to “Setting up tree collisions”)