No controllers using the latest SteamVR with 2017.1

I did the following:

  1. Installed the latest Unity 2017.1 release candidate.
  2. Imported the latest version of SteamVR (v1.2.2) via the asset store.
  3. Per the SteamVR Quickstart PDF, I clicked on MainCamera, added a “Steam VR_Camera” script, and then clicked Expand.
  4. This didn’t work at all (moving the headset did nothing), so I went to Player Settings > Other Settings, checked “Virtual Reality Supported” and added the OpenVR SDK.

That got the headset working, but now the controllers don’t show up. The “Steam VR_Update_Poses” script (which fixed the previous version of this issue) has been deprecated and now only removes itself.

Supposedly the latest version of SteamVR (1.2.2) solved this, but that is what I have installed and it’s not working. I’ve also tried using the previous version of the SteamVR_Update_Poses script, but that has also not helped.

Anyone know how to resolve this?

Thank you.

I have the same issue and haven’t found a solution, anybody else having this issue or should we go back to a prior version of Unity? If we go back, which version and which version of SteamVR should we use?

I am having the same issue here, since updating to the newer SteamVR version my (Riftcat/PSMove) setup doesnt work anymore, the only way I can develop games until I can buy a better PC and a VIVE.

I cant move the HMD, in this case my phone using Riftcat. Also doubt the controllers are working without the script mentioned below.

Previously I could just apply the Steam VR_Update_Poses script to the camera eye in the Camera Rig, this no longer works as you said.

Anyone here who knows how to fix this???

Also going to tag along. New project in 2017.1 with a SteamVR [CameraRig] object. Head tracking works but the controllers simply don’t show up. I know they are tracking because they cause holes in the proximity grid but other than that they are invisible. The common fix of using update_poses no longer works. I’m going through trying every combination of things I can think of but nothing quite seems to work.

Similar issues: I got the controllers to show up, and I can fire a teleportation beam, but I do not teleportation upon releasing the Vive thumbpad.
This is on a project that worked just fine in older versions of Unity…