No data available for this project?

[ EDIT: Updated this post because the previous problem got solved and now there is another problem. ]

I integrated Unity Analytics and now even though there's been over an hour since we play tested this is what it says on the data explorer.

7833666--992682--upload_2022-1-23_22-50-26.png

Just to be sure that I did all the steps right, I will write them here:

1- I "enabled" analytics on unity.
2- I downloaded the SDK.
3- Wrote all the necessary code for the custom events.
4- Playtested on an android device.
5- Waited over an hour.

Hey FoxAdventures -

First just to make sure you're talking about the new UGS Analytics features, where did you "enable" analytics? If it was in the editor, that step isn't necessary and you can turn it off.

Once the SDK is installed and you've linked your Unity Editor project to one in the dashboard (click the cloud icon in the editor) you should be good to go.

In the Unity dashboard for Analytics, check the Event Browser to see what events have come through, both valid and invalid. The event browser is really useful for getting started as it shows events in 1-5 minutes (rarely as long as 10 minutes)

You can use that to get started.
Make sure you've run through the three "getting started" steps in the docs, if events aren't appearing in the event browser, then a step was likely missed.

https://docs.unity.com/analytics/GettingStarted.htm

1 Like


Please share the code that you are using and a screenshot of the events and parameters you've defined in the dashboard. In the past, you've been mixing Legacy and Beta Analytics so I wanted to confirm.

[quote=“JeffDUnity3D”, post:3, topic: 869276]
Please share the code that you are using and a screenshot of the events and parameters you’ve defined in the dashboard. In the past, you’ve been mixing Legacy and Beta Analytics so I wanted to confirm.
[/quote]

Just checked Analytics again- turns out it was just later than usual. No problem here. Also, that incident was very useful to me-- I’m still having my troubles with the Analytics but finding things a bit easier to navigate. Thanks!

1 Like

hey @JeffDUnity3D having the same problem.I am using Legacy Analytics. The standard events are being registered but none of my custom events are being registered.

You’ll want to move away from legacy Analytics as soon as possible. It takes a day or two for custom events to show, so give it more time most likely. One note, ensure to check the return value

AnalyticsResult ar = Analytics.CustomEvent(…);
Debug.Log("Result = " + ar.ToString());

For me it took 4 hours. I think the text on the get started page is misleading here Get started with Analytics (unity.com)
[quote]
When you have purchased UGS, it can take up to one hour before your pipelines are available and set up.
[/quote]
In the technical docs somewhere I have read that the actually first display is more than 1 hour.
Anyway, via the Event browser, I could quickly validate if my integration was right. There the delay is around 5-15 minutes according to my experience.