No Git Executable Was Found

Hey hey,

Whenever I add a package now from a git repo I receive the same error:

**Project has invalid dependencies

Not ‘git’ executable was found. Please install Git on your system and restart Unity.

Git has been installed on the machine for a long, long time, but I reinstalled just to be certain I didn’t miss anything and to make sure the cmd was added to the system PATH variable.

Tried with github (public repo) and bitbucket.

Still no luck.

Anyone have ideas on this?

I would appreciate it!


(Using 2019.1.7)

So, the problem was all about Git and PATH environment variable. Here is a good StackOverflow answer which gives more details on Git PATH on Windows: Git: Installing Git in PATH with GitHub client for Windows - Stack Overflow

Former comment

A few ideas:

  • Try to run Unity with Administrator privileges (if this work, your user PATH is messed up, or you have wrong user permissions)

  • Do you run Windows 10 or a former version ?

  • Do you run a NT version of Windows with strategy rules ? Check if they don’t block

  • Did you try with another version of Unity ?

  • Can you copy-paste your PATH environment variable ?

  • What does git or git.exe returns when executed from cmd.exe ? from powershell ?

In my case git.exe and git-lfs.exe files were in different Folder (C:\Program Files\Git\cmd) I showed the new related paths in unity and pushed the button Find System Git. and it worked.