no input from oculus rift controller buttons (OVRInput)

simple question:
does anyone having issues with getting button input from oculus rift controllers using the current oculus integration asset (ver. 1.37) from the asset store?
do the methods like

// returns true if the primary button (typically “A”) is currently pressed.

and such (
still work?
I’m new to working with oculus and still quite new to unity, but right now even the demo scenes from the sample framework delivered with the oculus implementation asset have dead buttons.
Tried unity versions
to no avail. Not even the finger poses of the avatar’s hand change, when removing fingers from buttons. I’m pretty sure they did couple of days ago, when I had the very first tests of the implemetation asset. Yesterday the oculus app forced an update. Is the implementaion asset outdated now?
This is the exceptional case for me to write in a forum, usually I find all the answers by googling and reading. Thaks for replying kindly

What I found out so far is: the controllers stay dead if you run your test, but don’t cover the headset’s inner sensor, the one that indicates “user’s head is in the headset”
means that

OVRManager.HMDMounted ()

must have occured at least once, after start.
then the controllers are fully active and stay so even after HMDUnmounted occurs. Which is weird, but I’m ok with that. No need to put stickers on the sensor :slight_smile:

This can not have been the actual issue. Since I had the headset on my head and covered the HMDMounted sensor etc.
Still no idea, what the bug actually was.
Last night the controllers and avatar’s hands suddenly started to behave as they should. Buttons reacting, fingers moving.
I literally didn’t change anything, compared to all my efforts over many days before. I even worked on in the same project and same scene, just using keyboard input (since controller buttons would be just a “nice to have” for my current setup)