No matching function for call to 'OrientView'

Since I upgraded to Unity 4.5.1f3, I am now receiving this issue when trying to build an iOS project with Xcode 5.0.1:
Semantic Issue: Classes/UnityAppController.mm:104:2: No matching function for call to ‘OrientView’

A little digging let me to discover that UnityAppController.mm is calling this:

OrientView(_rootView, orient);

However, the actual function definition in iPhone_OrientationSupport.mm is this:

void OrientView(UIViewController* host, UIView* view, ScreenOrientation to)

So, there is a parameter mismatch. But, I have no idea how to fix that. I didn’t have this issue before upgrading. Is this is bug with Unity 4.5.1? Any suggestions how I might resolve it?

I’m actually seeing a similar issue after upgrade to 4.5.2.

Latest version of XCode 5.1.1, problem persisted after updating to the 6 beta.

Tried a clean Unity project and it worked.

I can only assume that this is due to a PostProcessBuildPlayer script that’s copying over an older version of the UnityAppController.mm file from within the project (common with plugin integrations like Flurry).

Updating that now with new version generated by the clean project.

EDIT:
True, this function now has a new signature:

OrientView(_rootController, _rootView, orient);

There’s also a few instances of iOS8 specific detection variables that need to be updated.