No monobehavious scripts in the file

Hi,
I am just starting to learn Unity (just yesterday) …well “trying” to start learning until i got this annoying error.

I just create a C# script in a new project and right from the beginning i get hit by a “all compiler errors need to be fixed …bla bla bla”

even though the project is freshly new, no other scripts are there only this new one. the error keeps popping. if i delete the script everything goes fine. i try creating a new one and the problem appears again. i searched for two straight days for a fix with no results. so far i tried doing this :

  1. made sure the name of the class and the name of the file are exactly same (lower upper case included). keep in mind this happens even if i just click create script with no change.
  2. did the refresh reimport all from the assets menu.
  3. delete all projects and reinstall unity again.
  4. disable antivirus software
  5. restart windows over and over
  6. restart unity and try deleting all projects and documents and create fresh ones.
  7. tried both monodev and visual studio both show no errors in the script.

I am running the latest version of unity (5.6) on windows 10 with latest updates.

Would really appreciate the help on this one. its driving me crazy but i am really into learning this thing.

Hello!

I think your problem is with the local language unity uses by default in windows 10. You’ve to open the sittings using (Windows Key + I) then choose (Time and Language > Additional time and regional sittings > Change Location). Open Administrative tab and click Change system locale and choose English (United States) and just restart and it will work like magic :slight_smile:

It worked for me and I hope it works for you :slight_smile:

Have a nice day.