No PC, Mac & Linux Standalone module loaded???

[SOLVED] Hello, So I wanted to export my game for windows, but it says there no module loaded for pc, mac or linux?
Can someone tell me how to fix this problem? The only Platform I can export my game is Web Player. Can anyone please help me in this problem? Thanks

2 Likes

You can choose what modules you want to be installed when installing Unity 5.3. Make sure you got them selected when installing.

For some reason they aren't selected by default so you can easily miss this important step.

4 Likes

Thanka for the help! :)

i was freaked out when i found i cant get builds for windows. thanks for your answer @Hertzole , it's such a huge design mistake to not install build modules by default.

In my case the problem was Visual Studio. The Visual Studio component that is included in Unity did not install correctly. Because of that the Unity installer quit after installing Unity but before installing any build modules. I did not notice that the first time. So make sure that the installer runs until the "Completing the Unity setup" dialog window is shown.

5.3.1 installer from here: https://unity3d.com/get-unity/download/archive doesn't have support to download anything other than Unity and MonoDevelop. How can I download other modules? try an old installer?

EDIT: Just downloaded a download ASSISTANT from https://unity3d.com/get-unity/update which has all the modules available. Really confusing if you ask me..

6 Likes

I actually checked everything on the list when I was installing it, but I still don't have them.

In my limited experience, it will often fail the 1st time you do this and you must manually install the desired modules but then next time you run the upgrade assistant it will then correctly uninstall and install all the modules. I leave mine running over night.

And I did have a Windows 10 blue screen while it was running - something I'm getting more of in Windows 10 after having them almost completely vanish from Windows Vista - Windows 8.1. If that happens to you, the Unity upgrade assistance won't know what it's completed - you need to start it all over. :-(

No it’s not, doing it your way would be the exact opposite of efficient. Only downloading and installing modules one needs saves bandwidth on both ends and creates less clutter on development machines. That’s why they’re called modules. And it’s not as if the Download Assistant is convoluted. It literally couldn’t be any more straightforward.

Did you install using Download Assistant?

Well, if there is an option in Visual Studio to install a Unity plugin, it would make sense that this plugin offers the same moduls to install too. Instead to download another Installer from a random page, not knowing how that will work together:
will this installer see what is already on the system or will it download unity the complete package again?

Basically there is not much straightforward here. Sadly i had to figure out the same hassle beforw while installing Visual Studio 2015.

So, after all that, what do i actually do to fix this problem. I don't really like the idea of reinstalling unity completely because I have very fast internet and started it up at night and in the morning ( 8 hours later) it was only just finishing up. Any manual way to install the required modules?

I'm being company vpn/proxy and cannot use the download assistant.
How to I solve this without using the download assistant?

Do I have to uninstall unity?

No, just run the download assistant. It's really very easy. Click the stuff you want, click install. The end.

--Eric

That’s a fine idea, except when using the download assistant results in an afternoon of error messages like this:

And this:


Given the ongoing crapshow that is the Unity download assistant, “it’s really very easy” is a very trite reply to the very real problem of having a simple way to install Unity with the modules that you want, all without wanting to smash your PC.

I haven't seen any messages like that; it's always worked fine here. Anyway that's unrelated to the question of stuff like uninstalling Unity.

--Eric

Same problem here.

No one answered him…

I need Unity 5.3.X for Windows 32bits. And I need the “Windows Build Support” option. How can I do that ?
If I use the “Download Assitant” : https://unity3d.com/get-unity/update, I can’t choose the 32bits version, and I ll automatically get the 64bits version (which is not compatible with my project).
If I use the Unity 5.3.X installer from here : https://unity3d.com/get-unity/download/archive, I can’t get the “Windows Build Support”, since it doesn’t have any other option than Unity and MonoDevelop. Here a screenshot :

So, is it impossible to get Unity 5.3.X for Windows 32bits and the “Windows Build Support” option ?

1 Like

So, is it impossible to get Unity 5.3.X for Windows 32bits and the "Windows Build Support" option ?

  1. Install the windows editor 32 bit: http://netstorage.unity3d.com/unity/910d71450a97/Windows32EditorInstaller/UnitySetup32-5.3.3f1.exe
  2. Then install the windows support: http://netstorage.unity3d.com/unity/910d71450a97/TargetSupportInstaller/UnitySetup-Windows-Support-for-Editor-5.3.3f1.exe

Make sure to install in the same folder.

If you need a different version.. use the same hash and version number as the UnitySetup32 URL is using, to construct the Windows Support URL. Unfortunately it's missing from the archive website.

Unity5.4 will include Windows support in the Windows Editor Installer, and the same on mac.

Best regards.

3 Likes

Okay. So how do you get Windows build support on Windows for Unity 5.3.4 64 bit? The URL including the hash seems to be hidden behind a pull-down menu.

There's an "Open Download Page" button but it doesn't work.

Why is the new Unity so much worse than the old Unity? Why are they actively removing key features? "Oh, we're gonna put Windows compile back into the Windows Installer, and likewise for mac." Am I supposed to thank you for your generosity? What if I'm on Windows and I want to compile for Windows, Mac and Linux? LIKE UNITY HAS ALWAYS LET YOU DO RIGHT OUT OF THE BOX.

Stop altering the deal, you soulless corporate suits.

Edit: figured it out, I think. Link for my version is http://netstorage.unity3d.com/unity/fdbb5133b820/TargetSupportInstaller/UnitySetup-Windows-Support-for-Editor-5.3.4f1.exe

32/64 bit is apparently not reflected in the URL, apparently. Right-clicking on the pull-down menu gives you the opprotunity to copy the link target.

The rest of my rant about Unity's new business model and tactics still stands. You used to be better than this, Unity Team.