No shadows in OpenGL ES 2.0 emulation or on Android - why?

So I finally managed to deploy my first test Android build, in which I force OpenGL ES 2.0 rendering path to have it compatible with wider range of devices (and OpenGL ES 3.0 doesn’t work on my phone).

I noticed I get no shadows when running Editor with Graphics Emulation > OpenGL ES 2.0 and I don’t see shadows when running the build on my device. I tried going for lower quality shadows settings, and while those changes reflect in the Editor when running in normal, not emulation mode, as soon as I switch to GLES 2.0 emulation or deploy to the device - shadows are completely gone.

All I use is 1 directional light. Running Unity 4.6 whatever is the latest, trial version (basically like Pro). Shouldn’t really make any difference regardless of the version.

Thanks.

Apparently the issue was with Quality settings - solved.