No Shadows in Unity 5?

I’m using Unity 5 Personal Edition. i’m not seing any Shadows. I’m using a Directional Light and it have Shadows activated. The cube I’m using to receive Shadows can receive them. And the object that should produce Shadows have Shadow Casting activated.
Othe Effects like Bloom, Radiosity/GIA and SSAO (Ambient Occlusion) work fine.

Look in Edit > Project Settings > Quality.

Try a bigger value for the Shadow distance

Turns out i didn’t have the ‘Good’ option ticked for the platform I was using. I fixed it by allowing it and setting it to default by the little down arrow at the bottom of the quality preset selector.