No shadows.

Why are there no shadows in my current game, but there are in my previous ones?

I have the exact same settings on both. And both are also for Android.

Quality Settings has Both Shadows on. The Directional Lights has shadows on. The 3D objects in the game have shadows on. Render Mode is also set to Important, and Rendering Path is set to Forward. But I still couldn’t see any of them. No shadows whatsoever.

What’s weird is that, as I said earlier, in my previous game, everything works fine. This game has the exact same settings as the first one (or maybe I’m missing something), and there are still no shadows appearing in my current game.

I also have the latest version of Unity, which is 4.5.5.

I’ve tried searching everywhere on Unity Answers, Unity Forums, and Google, but none are helping me at all. All of it ends with the OP solving the problem with a solution that doesn’t solve mine, so I decided to make my own :stuck_out_tongue:

Thanks to whoever can help! :slight_smile:

Just found out that the shadows appear on my android when built and ran. So that means the shadows doesn’t appear only in the Editor. Now, how do I enable the shadows in the Editor? My previous game can still show shadows in the Editor, but not this one :confused:


What makes you unable to see the shadows in your game is “Your main camera isn’t able to detect shadows”
To fix that, select the camera in the Hierarchy then in the Inspector in the “Camera” component change Rendering Path to anything else;

Maybe you need to change your shadow distance? project settings> quality