No Sound at all

As the title says I have no sound at all. The first time I started Unity there was sound in the demo project (Angry Bots).
I didn´t open Unity for quite a while but now I startet with my fist project and I want to add sound to it (a .wav file) but it won´t play. Not even in the inspector or the preview. If I double click it, it opens in vlc and I can hear it but thats it.

To be sure my soundfiles aren´t the problem I re-opened the demo-project and it´s not working there either. When I click on a soundfile and try to play it, nothing happens. No error, nothing in the console, only when I try to click another soundfile it says "Unapplied import settings for “path of my asset file”

Can anyone help me?

I just solved the problem! I´m feeling like an idiot and had the biggest facepalm ever! I´m pretty new to windows 7 and somehow the audio for unity was muted but not for my other programs! (didn´t even knew this was possible)

Thanks for your help, I´m going to smash my head on the wall :smiley:

this worked for me and I’m on a mac-

Nevermind… I, too, solved the problem. But, it had nothing to do with Windows 7. Instead, I opened the default Unity project, Angry Bots, and I ran that project. The sound worked fine. I then opened my project, and guess what… the sound also worked fine! So, if you can’t get your sound to work, try opening the default project in Unity and running it. It seems to “kick-start” Unity’s sound capability for some reason.

For me someone else in the project had set the Edit>Project Settings > Audio global volume to 0. There is also a tickbox there to disable Unity Audio.

The basic way in adding sound to your game is to add the wav file to an object within your scene (like a cube or an empty object). By default, it won’t loop, it plays automatically, and the volume may depend on where your audio listener (such as a character or camera) is in the scene regarding the object with the sound (aka audio source); the farther the distance, the quieter it will be and vice versa.

I’m only explaining this because I don’t know if you’ve attached it to anything in the scene just by reading your post. Good luck!

These are 2 of the ways this can happen:

  • At the top of the “Game” window is a button with the text “Mute Audio”. Make sure this isn’t pressed in.

  • Edit - Project Settings - Audio - Make sure “Global Volume” is 1 and Disable Audio is not checked

I experienced similar issue with the sound not playing in web player after publishing but working fine from within IDE every I would test the game.

In my case it was semething to do with using AudioSource.PlayClipAtPoint() method which didn’t seem to work properly. After I replaced it with audio.PlayOneShot() it was fine.

If you want to read more I elaborated on that writing Unity3d web player doesn’t play sound

In my case the Edit->Project Setting->Audio->System play rate was set to zero
I give it value 1 and it worked for me

If you still can’t resolve this issue, press little speaker icon in scene window. It apparently requires a restart to work it. For me, audios didn’t play even in inspector.

If someone using VR oculus, in using headset(oculus home) try this “setting - headset - audio output” and select ‘windows default’

Super old post, but I found my problem was that the “Mute Audio” button was accidentally toggled on. I’ve used Unity for years but never even notice/remember this button as it’s pretty discrete.

Unity also has its own “Mute Audio” button that is located under the “Game” tab. If you press this by accident you might experience some extreme frustration trying to get your audio back.

pressed Windows Key + G to open up recording and unmuted unity then it worked for me