No tranform animation on root bone from maya.mb

Hello everyone, this is probably a simple question to answer (hopefully) and i'm just being thick but here it is.

I have a rigged and weighted character imported into unity from maya 2010 in the .mb file format. I have baked the animation in the import settings and the character animates fine on first glance when I preview the animation, however on further inspection I have noticed that the character animates on the spot as if on a treadmill and is missing some of the animation that really gives the character a feeling of weight shifting. For example for a walk cycle the character has no lunge - forward motion - to it, the animation of which was a transform set to the root bone at the characters center of gravity - the hips/spine base or root bone, whatever you want to call it. Having done a bit of research before posting I have found that unity appears to cancel out these translations due to character movement generally being controlled by player input through scripting, which is fine, but the character in question would be a npc or cut scene character and NOT player controlled

So far I have tried adding another bone to the hierarchy set to the 0,0,0 in maya world coordinates and parenting the original root bone, and thus the entire rig, to that new bone hoping this would give the original root a point of reference and solve the problem. This was not the case.

So my question is how do I enable transform animation on the root bone of a character? I assume there's an option box to check somewhere that I can't find or something as simple as this because otherwise it seems like too big an oversight by Unity to just be left out. If someone could help out or at least point me in the right direction it would be much appreciated :)


Unity doesn't cancel out any tracks. At least nothing comes to mind. Maybe you need to bake your animation or something like that. Do you use some special controller to play your animation which overrides aniamtions?

Same stuff here. Animations imported from blender - everything is fine, however root bone is still, that’s why character is stuck in space, no weight animations applied. :frowning:

Same problem here, has any one got the way for this!

Same peoblem, has any one got ways of importing animations that work well for npc.

I somehow solved this simple way. I left one bone unchained, but as parent to rest of bones, i.e. not connected to rest of skeleton with bone, but PARENT. Then I animate all bones as I want, but I don’t touch root bone. And it works. link text