No valid license found, Machine Bindings error

When I try starting a project I get the infamous “No valid license” error. I’m almost certain it has something to do with the fact that I initially started fiddling with Unity on my laptop and then I migrated to my PC (probably improperly).
At first it was working with 2020 Editor and not with 2021 but then I reinstalled Unity and now it doesn’t work with any version of the Editor. Also, Hub 3.x.x is completely broken on my PC; nothing license-related works. It works flawlessly on my laptop though.
That means that I’ve been getting the error message in the 2.x.x Hub.
When I check the logs I see these errors:
Machine binding 4 mismatch: (value of current machine) w7sU != (value in license file). Reason might be there is a hardware change on this machine after the license was activated.
and
Error: Code 500 while processing request (status: Unable to update licenses. Errors: Machine bindings don’t match,No license activation found for this computer.)
I tried EVERYTHING.
From running as administrator to manually activating the license file to reinstalling to creating a new ID and creating a new license… you name it.
Nothing worked.
I’ve been to every link on every website and there’s simply no more options. Please guys if you know something about this, help me. Thanks in advance!

I've been having the same issue as of today, yesterday I couldn't get Unity Hub to recognize my free license, today, I'm getting this error in the log... Has anyone managed to find a fix for this?

I ended up fixing it but I don’t think you’re going to like the way I did it.
I had to replace the motherboard because the serial number was corrupt and the Unity licensing software couldn’t read and generate the license.
To check if you have the same problem do the following:

  • Open your command prompt and type ‘wmic bios get serialnumber’
    If you get “Invalid XML content”, you’re going to need a new motherboard
    I tried everything else but in the end I just had to replace it