None of your spec sources contain a spec satisfying the dependency: `Firebase/Analytics (= 10.0.0)`.

We are trying to use Firebase Analytics but when we build our Unity project we get a CocoaPods installation failure:

None of your spec sources contain a spec satisfying the dependency: `Firebase/Analytics (= 10.0.0)`.

You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.


Ignoring ffi-1.13.1 because its extensions are not built. Try: gem pristine ffi --version 1.13.1
Ignoring json-1.8.6 because its extensions are not built. Try: gem pristine json --version 1.8.6

pod repo update output:

Updating spec repo `cocoapods`
  $ /usr/bin/git -C /Users/josephhopkins/.cocoapods/repos/cocoapods fetch origin --progress
  $ /usr/bin/git -C /Users/josephhopkins/.cocoapods/repos/cocoapods rev-parse --abbrev-ref HEAD
  master
  $ /usr/bin/git -C /Users/josephhopkins/.cocoapods/repos/cocoapods reset --hard origin/master
  HEAD is now at 7b2edeb16678 [Add] SwiftCurrent 5.1.10
Updating spec repo `trunk`

CocoaPods 1.11.3 is available.
To update use: `gem install cocoapods`

For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.11.3

We are using Unity 2020.3.8f1. We tried deleting the Library cache folder but error still happens.

How do we fix this problem?

I was able to fix by deleting all Firebase related files and reinstalling.