not compiling for android

ever since i updated to unity 4.5 i got errors saying that the minimum required platform api is 14 (4.0), so i updated my sdk and now im getting this error in the consol:
Error building Player: Win32Exception: ApplicationName=‘C:/Users/lee/Documents/sdk ools\zipalign.exe’, CommandLine=‘4 “C:\Users\lee\Documents\war\Temp/StagingArea/Package_unaligned.apk” “C:\Users\lee\Documents\war\Temp/StagingArea/Package.apk”’, CurrentDirectory='Temp/StagingArea

help please

Step1: Go to your SDK Folder. Example: (D:\Program Files\Android Java\sdk)

Step2: Open The Folder “build-tools”.

Step3: Find your build folder. (Most likely to be the folder with the hightst number)

Step4: You now see a file named “zipalign.exe” Example: (D:\Program Files\Android Java\sdk\build-tools\19.1.0\zipalign.exe)

Step5: Copy the zipalign.exe file to SDK ools. Example(D:\Program Files\Android Java\sdk ools)

Step6: For best result restart your PC.

This was a bug that got fixed in Unity 4.5.2 (see release notes here: Unity 4.5.2 Release Notes

Simply get the latest version to resolve your problem: http://unity3d.com/unity/download