Not instantiating certain prefabs in WebGL build but works fine in Unity Editor

All of a sudden, I have developed the problem in the title. There was a ‘slip of the mouse’, and I think I might have accidentally changed something. After searching around, I have a feeling it might be something to do with one of these (but it could well be something else!):

The Graphics Emulation settings (currently ‘WebGL 1.0’ is ticked and ‘Shader Hardware Tier 3’.

In ‘Other Settings’ of the PlayerSettings, Auto Graphics API is not ticked, and WebGL1.0 is above WebGL2.0 below that.

I don’t think it’s a coding issue as previous versions worked fine, and it still works instantiates the prefabs in the Editor.

I’d really appreciate help with this… I’ve just overwritten my back-up, which worked fine!

Thanks

EDIT: I just tried a PC Standalone build, and that had the same problem,. It instantiates some things, but not others.

I don’t know what I’d done wrong, but I reimported assets (under the ‘Assets’ header), and it fixed the problem.

I got the answer from this useful page:
https://forum.unity.com/threads/script-not-working-in-build-ok-in-editor.40806/