NSIS Error for Unity 4.0.0

I downloaded Unity 3D v4.0.0 but when I try to install it, it performs a self-check, and says NSIS error:5673-capture.png

I also tried v3.5.6 , but the same error appears. The download wasn’t corrupted(unless the file is damaged on the server), I don’t have any VIRUS in my PC. It could be that some file needed on my computer is missing… I tested the setup with an unzip program, and it says that around 180 .pdb files in the setup are broken.

I need help with this… I visited sf, but it wasn’t of any help…

It appears that Monodevelop is broken, as when I run it using /NCRC with command prompt and uncheck install Mono, it installs without a problem.
If I installer Mono from monodevelop.com, it does not work with Unity… so I guess I have to install the one with Unity. Can I install mono for Unity separately?

It has been my experience that when you get the integrity error that the download failed to complete correctly. I had this happen in chrome a couple times, you may want to get a download manager or something similar. NSIS installer will still execute if the file is corrupt. Another option, use another browser.

Monodevelop downloaded from monodevelop.com is missing all the wonderful customization that Unity put into their package, like debugging and scripting helpers/popups/etc, please be aware of that. What you downloaded was working as designed, but without all the unity hooks and sweetness.