NullReferenceException with Animator

I’m trying to import some animations, I have the model and the animations imported in FBX, but I always get this error. What is it means? I don’t get to play the animations.

NullReferenceException: (null)
UnityEditor.SerializedObject…ctor (UnityEngine.Object obj) (at C:/BuildAgent/work/cac08d8a5e25d4cb/Editor/MonoGenerated/Editor/SerializedPropertyBindings.cs:60)
UnityEditor.Graphs.AnimationStateMachine.TransitionInspector.SetTransitionToInspect (UnityEditorInternal.Transition transition) (at C:/BuildAgent/work/cac08d8a5e25d4cb/Editor/Graphs/UnityEditor.Graphs/AnimationStateMachine/TransitionInspector.cs:173)
UnityEditor.Graphs.AnimationStateMachine.TransitionInspector.OnEnable () (at C:/BuildAgent/work/cac08d8a5e25d4cb/Editor/Graphs/UnityEditor.Graphs/AnimationStateMachine/TransitionInspector.cs:96)

I recently had this exact issue.

Situation (may or may not had to do with the issue):

  • Unisntall old Unity version, downloaded new version of Unity (4.5.4f1)and installed
  • I realize that folders Editor and Monodevelop of old unity weren’t deleted
  • Uninstall new unity, deleted folders Editor and Monodevelop, install again

What I think solved the problem:

  • create a new project in a different folder, import same assets you imported in the project having the issue.
  • copy your created assets from old project with issue, paste in new project

It solved this log errors. Altough when getting this log errors I did could play animations.

Other suggestions:

  • In blender (and perhaps in other 3d moldeing program) all animations must start at frame 1