Nvidia Optimus latest drivers broken with Unity

I use a laptop with an integrated Intel HD 4000 Graphics and Nvidia GT640M GPU. Nvidia Optimus allows applications to render with Intel or Nvidia based on settings in the Nvidia Control Panel. With recent Nvidia drivers, this seems to be broken on my laptop. Unity is using Intel, regardless of my settings in the Nvidia Control Panel. Even if I right-click on the Unity shortcut and select run with Nvidia, it still defaults to Intel.

If I revert to Nvidia drivers 320.49, the control panel options work again.

This can be confirmed in Unity by right-clicking the Console tab, clicking on ‘Open Editor Log’, and looking at the first lines of the log. Anyone else having this issue? Is this an issue with Nvidia’s drivers or Unity not honoring the user’s Nvidia preferences?

Fixed! I was using Dell Display Link drivers with a SuperSpeed USB 3.0 Docking Station. Removing the Display Link drivers and not using the docking station solved the issue.