Object dos not match with the mesh collider

The mesh collider component doesn’t line up with the object itself, I tried to make an empty object and add the mesh collider to the empty object, but it didn’t work so… the error appeared when in the original object added the mesh collider compoment and…you can see it in the image:

You’ve checked IsConvex. Uncheck that to get your actual model.

Convex is an optimizer that will reduce poly count on your actual collider by removing gaps / holes.

The mesh collider will take on the shape of whatever mesh is plugged into it. You have to plug in the correct mesh for it to work properly. Also, if it is a complex mesh, and you need it to be complex, make sure you have “convex” and “smooth sphere collider” unchecked.

it’s up to you to make sure you’ve got the proper mesh attached.

To set the mesh of a mesh collider, simply select the “mesh” field in the mesh collider component in the inspector and edit it.

Go here for more information on mesh colliders.