object subdivision - pipe looks more rounded than original object during play.

Hello!

I have a pipe imported from XSI as an .obj. It looks more rounded than the original object, but I wanted the low-poly faceted look. Is Unity3D already subdividing it for 'play', somehow? If so, how can I disable it?

Also, could anyone recommend the best format for importing models from XSI, please?

Thanks!

You have probably recalculated the normals at import. Switch that functionality off and it should be all right again.

Does the silhouette also look more rounded, or just the shading? Looks to me that either Unity is computing smooth vertex normals (go to the Inspector import settings of your object and make sure that "Generate Normals" is disabled), or your XSI object does have vertex normals somewhere, which you don't want, or the XSI->.obj exporter is buggy.

FBX should be a pretty safe choice as an interchange format.