Objects move on play

I’m making a sort of strategy game, and so far I have one map and five village objects which are loaded from a prefab but have different scales and names. The problem is that when I hit play, they all move to 0,0,0 translate and 1,1,1 scale. I’ve noticed that in the inspector, the translate and scale are both bold, what does it mean and how do I fix it.

Do your meshes have animations? I noticed when I import a mesh with no animations from blender, and I leave the animation import settings alone, my game objects pop to 0,0.

To fix this I just went into the import settings, and set it so Unity does not import animations. That fixes my problem.

I have same problem, I created AK47 in Cinema 4d with some keyframes 1-100 idle and 101-150 fire, when I add the toy into Unity it’s moving to 0.0.0 once I hit play (Command+P) and I’ve notice that it happends only when my automation set to LOOP. If you have a solution please write it down please. Thanks

@UCRussian this might be late but:

I had the same issue and it turned out the animator component was attached to an entire group I imported (a group of 3 meshes, 1 of which was the mesh that was animated). This group was nested inside a parent folder. After importing into Unity, I had moved all but one of the meshes around. When I pressed play, all the meshes moved to the transform position of the one mesh I didn’t move. The problem is indeed solved by turning loop off. But, since I wanted my animation to loop, I solved it by readding all the objects to the scene, and making sure that when I moved them, I moved the entire group, and not any individual meshes.