Objects with animation disappear in IOS build.

Running on a MacBook Pro
Unity version 5.3.2f1
XCode version 7.2 (7C68)

I am having an issue where I have an animation applied to a coin making it rotate. The coin that is rotating is a child object of an empty named Coin. There is a spot light that shines on the coin that is a child of Coin as well. When I run project from Unity I see the coin rotating and the spot light. The same using Unity Remote 4 on my iPhone 6.
When I build for iOS and compile in Xcode to my iPhone, there is no coin but there is a spot light. I can still collect the coin and everything works as normal…just not rotating coin.

There are other game objects that are doing the same thing… Like a guy with a walking stick. His arm that’s holding the walking stick is missing in the iOS build. It’s the only part of him that’s animated.

All that being said, anyone know why this is happening?

Thanks in advance!

Same here… Only when we build on unity 5.3.x
5.2 is fine

In animation window, you can right click rotation property and set interpolation method to euler angles (quaternion approximation). This will make your coin rotating and visible again.
However, sometimes this property gets reset somehow back to euler angles, so about 1 in a 50 game launches you might get invisible object again. Still can’t find out why this property keeps resetting occasionally.

Same behavior !
My animation make some rotations and finish to the starting point.
The object is only visible at this position, so I see twice my object, at the start and the stop …
Unity 5.3.2f1

Seeing this exact same issue. Rotating and changing position in animation. Shows up in editor not on Iphone build. On Version 5.3.2f1. Seems to certainly be a bug on 5.3

I am getting the same behavior on Unity 5.3.2f1 personal edition. I had two cubes that were a child of an empty gameobject. The animator was attached to the parent and it was rotating the cubes. I saw the behavior @IceSheep mentioned where the cubes showed up only at the final position and not during the intermediate frames. That being said, I also later started having a different issue where I didn’t see the object appear on my iphone. If I moved the animator from the parent to one of the child cubes, the cube it was attached to disappeared. So the animator was just making the object disappear. All these animations work well on the editor. Only when I build to my iphone i see this issue. Any help or update on this is appreciated.

Unity says that it works in the new release, 5.4. Hopefully once it’s released the problem will be solved.

You can see their response here.