Objects with 'cast shadows' unmarked are still creating a shadow

alt text

Before lightmapping a level I went into this water object’s mesh renderer setting and deselected ‘cast shadows’, so it wouldn’t create that shadow underneath, but after baking it’s still happening. Also on other objects too. What am I doing wrong?

alt text

alt text

Cast Shadows is used for realtime shadows. Your shadows are baked. I am not a lightmapping expert but I guess you should untick the water from being lightmap static in the inspector for the water. Click the little arrow pointing down next to the static checkbox on your pond game object, and ensure it’s not “Lightmap Static