Occlusion Culling

I’m have trouble getting Occlusion Culling to work I’ve read the tutorials, googled it and watched the youtube videos but still can’t get it to work at all.

I tag all my static objects Occluder Static in the Inspector, I’ve tried setting my own occlusion area and also letting it set one up automatically, like the documentation says - NOTE: By default if you don’t create any occlusion areas, occlusion culling will be applied to the whole scene.

Then I’ve baked trying it with all 3 settings, PVS only, PVS and dynamic objects and Automatic Portal Generation.

Then when I run with a window set to Occlusion Culling so I can watch whats going on when I select the main camera and walk around anything out of the field of view disappears as expected, but nothing behind objects disappears, even when I stand right behind a building facing the wall everything the other side is still there.

So can anyone please help me and give me some advice ?

Hi Griffo,

Have you tried to set the static tag of those small object also with the occludee static? I understood from the documentation that all objects that you want to be “deactivated” when not seen by the camera, has to be tagged as ocludee. Try out and let us know.