Oculus Integration v1.39 and Unity 2019.2.0f1

A couple weeks ago I built an APK for Oculus Quest using Unity. It was a build of the Oculus Integration package’s SampleScenes. This build worked, it was rather buggy but it worked.

Then a few days ago they released a new version of Unity (2019.2.0.f1) and a new version of Oculus Integration (v1.39). Since the updates, I have been unable to get the new versions to create a functional build. I can output an APK using the Oculus Integration samples, but it does not run properly. When I load and run the APK on the headset It opens and runs the first scene (StartScene) with no problems but when I try to open the next scene it crashes.

It’s important to note I have touched none of the code. I started with and empty 2019.2.0f1 shell set up for android and VR. Then I downloaded and installed theOculus Integration Package v1.39 from the Unity Asset Store. I simply took the sample scenes provided by Oculus and loaded them into a build. I had to adjust the Player Settings but one would think this should work. I had it working a few weeks ago.

Also the test build I did for Oculus Integration, that worked and was on the headset, no longer functions properly at all. I did not reload it or touch this file in any way.

I feel Like I’m missing something. But what?

I am having a similar issue where none of the sample scenes from Oculus Integration allow for the controllers to work as expected. In fact, they are not even showing up. I know they are being tracked as they can break the planes of the virtual barrier. My hunch is that the latest firmware update from Oculus has changed something that is breaking the Oculus Integration functionality. Hopefully someone will get to an answer on this quickly.