OnGUI mystically stopped rendering buttons and text.

Hi. I just started unity again after a one-week break from my project and encountered a problem with the GUI. It worked perfectly before I took my break and was certain it was the editor that had a bug or something like that, but I tried to reinstall unity and the “bug” was still there. Now I have no clue of what may cause this. Any help or suggestions would be appreciated.

PS. I will not give you any code to look at, because of the simple reason that it is not the code that is causing this, since it worked one week ago and has been untouched ever since.

Do you have disabled your script component or the whole gameobject?

Check this while your testing, not at edit time. There could be another script that disable your actual script.

There’s not much more which could cause this. Maybe you use GUILayout and you have disabled the layout event?

Without more information we can’t say much more about this…
Debugging is up to you since we don’t have anything to debug…