Only part of UI elements are interactable.


I’ve tried searching around for a solution to this issue all day and have had no luck. That being only part of particular UI elements seem to recognize input. Here’s a gif I made demonstrating what I mean. I made the highlight color red to help show what I mean. Does anyone have any tips for how I can fix this issue? It’s driving me crazy >.<

Thanks in advance,



I was able to solve this issue by following some of the steps in this question and discovered that I had another canvas that was active in the scene but was rendering to a camera that wasn’t active. Solved that and now its working perfectly! Thanks for all the help everyone!

It is good to have gif for the issue and is very helpful to others for finding out the solution of the problem you have.

Solution :
You have an element (showing the difficulty) between < and > buttons.
That element has width overlapping both < and > buttons.

Sol 1. So just decrease the width of that element and it works fine.

Sol 2. In hierarchy window, move < and > elements below than the difficulty element (that is in between < and > buttons).

Let me know if you need more help.