Orthello 2D: Pixel-Art without any blur

I would like to create a game with some pixel-art, but when I try to import a sprite and then give it a texture, the sprite has some kind of blur. How can I change it, so that I can see sharp pixels with sharp edges?

Thanks!

As you are interested in pixel art, go to the import settings of your textures and change the “Filter Mode” to “Point”. This will stop Unity from interpolating between pixels.

Also make sure your original textures have a power-of-two resolution (e.g., 32x32, 256x128, or similar), because otherwise Unity will resample your texture, making it blurry/washed out. Yes, this also is true if you were to explicitly disable “Non-Power of Two” scaling in the importer (unless you exclusively use your textures in Unity GUI or in GUITextures).

Using Microsoft Picture Manager or Photoshop - Enlarge the texture from original size to 512

Be sure

Texture quality at full res and Anisotropic Textures at Forced on, from quality setings

And if your texture has big resolution. Select override for your platform and rise the max size from import settings

See this unity blog post for how to achieve pixel perfect 2d.
It’s unfortunately not just a ‘win button’.