OS X Standalone Deployment Problems


When I make a build in Unity 3.4.1 for an OS X Intel Standalone deployment no one else can open the .app bundle. They don’t receive the resolution splash screen and they don’t see the icon in the dock. It’s almost as if the application almost instantly quit. If I make a build as a dashboard widget the application works fine.

On my computer these builds work fine and I can launch them without any problems. I believe this problem started around the time when I upgraded to 3.4, but really hasn’t been a problem until now so I haven’t given it much though. I can make other builds and they seem to work ok, but OS X builds (both intel and universal) are not able to be run on another person’s computer.

For troubleshooting I have done the following without success:

  1. I have uninstalled Unity and reinstalled.
  2. I have repaired my disk permissions
  3. I created a guest account on my computer and launched the application from Applications/ and it didn’t have a problem.
  4. On the other person’s computer I went into the packaged contents and tried to launch the .exe by dragging it into the command line only they receive a “Do not have permissions” when they try to do this. (it works fine on my computer).

I’m wondering if anyone has had this problem or if anyone has any recommendations to do to fix a problem I’ve been having with making standalone builds in Unity. Does anyone have any recommendation or suggestions on what could be happening or any troubleshooting steps? The only thing left that I can think of is to try is to reinstall my operating system at this point.

Thank you in advance!

So I can’t log in under my “Ferazel” account anymore, but the answer is as follows in the Standalone OSX players can't start after having been through DropBox 0.7.110 - Questions & Answers - Unity Discussions

The problem is with OSX and it setting attributes on downloaded files due to security concerns. I was distributing the builds via iChat and it was incorrectly setting the .exe (yes it is located in the bundle under Contents/MacOS) In order to get around this all I needed to do was just .zip the file and the executable flag would not be changed.