Overcoming Mesh Colliders (car falls through street)

I have a street system of road sections, all with Mesh Colliders. I have a tank with Mesh Colliders and Wheel Colliders. I have a car with Mesh Colliders and Wheel Colliders. When the build starts the tank is ready to go but the car falls through the street. They both use identical wheel colliders and both have mesh colliders on everything.

I had to add Sphere Colliders to the Tire Meshes to stop the car from falling through the street. Once the build starts, I can delete the Sphere Colliders in the Editor and the car stays above ground. I can drive it all over with no trouble. Well, until the car flips, then it falls through the street into oblivion.

Both the car and tank use very similar (same but modified) code to move each vehicle.

The models are all very detailed. I can’t just add box colliders for many reasons (example: firing a bullet at a box collider allows a bullet hole decal to look like it is floating in the air around the mesh). I need to use Mesh Colliders so that the collisions are accurate.

What can I do to overcome the fact that Mesh Colliders do not play nice together?
Why does one Mesh Collider collide with one object but not the other? They’re setup almost exactly the same: the car has wheels, that tank has wheels resting on a track.

Note: setting convex on the tires does not stop it from falling through.
Note: both tank and car are set to continuous collision detection.

It appears that the problem is that the street is too thin. It is a plane with a mesh collider component attached. To solve the problem, either make the floor/street/ground thicker or in my case I put a box with a box collider underneath the street to stop it from falling through