Package Export (dependencies) broken ?

When trying to export a package, for example, a scene or just a simple prefab, with include dependencies checked, the whole project is included... Am i the only one having this issue ? I'm about to send a bug report, but i'd like to be sure that's it is not a local problem.

Edit : I should have wrote 'the whole project is selected'

apparently sometime it works, most of the time it doesn't :face_with_spiral_eyes:

Bug report case 704171
The workaround i've found is : select objects to export in the project folder, right click 'Select Dependencies', then 'Export Package...'

4 Likes

Hi Gruguir,

I'm running into the same issue. I've selected the prefab > right clicked > select dependencies > export package but it still exports the entire project. When I load the package into a new project it doesn't work. I've tried a number of times with blank files and nothing seems to work. Were you able to find a stable solution?

No, and the bug report case is still open.

Still having this issue 7/31/2016, with Unity 5.3.6f1.

5.4 is too buggy to test in, but I feel safe assuming this still isn’t fixed. So correct me if I’m wrong.

Entire project is exported anytime I select “Select Dependencies” even though I’m just exporting a package I had just imported (relies on nothing but what’s in a single folder that didn’t exist prior).

Thanks for the tip workaround guys!

Same issue still happening here in unity 2017.1.0.f3. Makes it very hard to integrate 2 games into one project.

2 Likes

did manage to get by this kind of by selecting the scene file in the project window and doing right click-> select dependencies, then right click ->export package, it seemed to only export what I needed!..

1 Like

Still broken in 2017.3.1f1.

1 Like

i'm finished with bug reports :rage:

What is the point of the feature if it doesn't re-assemble the project when you import? Are we suppose to re-attach all the assets manually then? When I used the export and import project feature, it was as if I was just re-doing the whole project again from the beginning for the most part. Is this just the way it was intended to work?

Still broken in 2019.2...

And the workaround still works...makes you wonder why they havn't fixed it if working code is intact but not being used when it should...

And yes, i bumped a 4 year old thread...because it's still somehow relevant in 2019+

Why the heck not just remove the checkbox if it doesnt work as intended and they have no intention of fixing it? it's tagged "Wont Fix" here: https://issuetracker.unity3d.com/issues/export-package-does-not-respect-select-dependencies-includes-everything

Soo, just remove the thing, less than a minute to remove this issue entirely. you could even make the intern do it!

2 Likes

Yeah, the workaround works somewhat ok for me. Just to be clear, to export for example a prefab or a scene and everything related to it, as previously stated: select it in the project window, right click -> select dependencies, right click again -> export package. The "Exporting package" appears and will have the whole project selected, but only the previously selected items with dependencies and a bunch of random files are exported.

Instead of exporting a few gigs, my export ended up being 6mb. Still, all of my scripts and a bunch of other things were included in the export.

1 Like

What if I have the opposite issue where no dependencies get exported, ever, even when selecting "export with dependencies"?

2 Likes


I'm facing the same problem here with unity 2022.3.1f1