“Packages were not registered because your license doesn't allow it” Warning

Hi all. We’ve received reports of some users encountering the following package license warnings:

“[Package Manager] The following packages were not registered because your license doesn’t allow it.
com.unity.polyspatial@file:/com.unity.lwxr/Packages/com.unity.polyspatial
com.unity.polyspatial.visionos@file:/com.unity.lwxr/Packages/com.unity.polyspatial.visionos
com.unity.polyspatial.xr@file:/com.unity.lwxr/Packages/com.unity.polyspatial.xr
com.unity.xr.visionos@file:/com.unity.lwxr/Packages/com.unity.xr.visionos”

To remedy this issue, please do the following:

  • Close your Project and quit Unity Hub
  • Delete ~/Library/Application Support/Unity Hub
  • Restart the Hub

This should force a reindexing of files and remove any additional warnings.

Still encountering this license warning after these steps? Please let us know here in the post and we’ll follow up!

I followed the directions (deleting ~/Library/Application Support/UnityHub not ~/Library/Application Support/Unity Hub which didn’t exist) but it did not resolve the issue for me.

Hi Alex. Beyond the usual “please ensure that you have updated to the latest version of the Hub and PolySpatial packages,” etc., can you please tell me if you have the following local files on your system?

/Users/$USER/Library/Unity/licenses/packages/packageAccessControlList.xml

/Users/$USER/Library/Unity/licenses/packages/packageAccessControlList.etag

If so, you can go ahead and delete them. You’ll then need to restart both the Hub and Editor. Let me know how it goes!

1 Like

Thanks, that seems to have resolved it (loading a project using 0.5.0). The files were not restored afterwards. I haven’t attempted to restart Unity using 0.4.3 (my current main working version) as I’m worried this will not be usable, is this likely?

Good to hear! The files should not have been restored.

0.4.3 should load ok for you now as well, but as always, we suggest you upgrade to the latest versions to ensure you have compatibility with the ongoing Apple SDK releases and our own bug and stability fixes.

Thanks for the info. https://discussions.unity.com/t/rendertexture-performance-regression-in-0-5-0/309178/2 is blocking update to 0.5.0 at the moment.

Thanks! Deleting /Users/$USER/Library/Unity/licenses/packages/packageAccessControlList.xml and the etag solved the issue for me, too.

1 Like

Hi everyone,
I am still seeing this warning in the console after adding com.unity.polyspatial via package manager.

As a note:
I am using a Unity Pro 30 Day Trial license.

Hello! The Pro 30 Day Trial is 100% compatible with the PolySpatial packages. Have you assigned the Trial seat to your account? Does the Trial License show in the Hub when logged in with the account that has the Trial?

If so, please quit out of the Hub and Editor + ensure you have removed the two potential files noted above from your system. Restart the hub and Editor and you should be good. Still have problems, please ping me back here!