Parallax shadder not working with normal's alpha

I have placed the height map in the normal map’s alpha channel.

However, when the texture is flagged as a normal map, the alpha channel is removed and the parallax no longer works correctly.

On the other hand if I set the normal map’s texture type to ‘texture’ the texture gets it’s alpha channel back and parallax shader now correctly uses it - but now the normal map does not work correctly and Unity keeps throwing up an error message wanting to ‘fix’ the texture.

The only way I have found to get both a normal map AND height map to display is to put the height map in it’s own texture, but this is not ideal as then I have to load another 32bit texture with three unused channels.

Am I missing something, why won’t normal maps keep their alpha channels?

Same troubles. I trying to make custom parallax shader through Strumpy shader editor, but it’s little difficult for me. can share result when it will done…

This is probably because it’s automatically selecting a compression type that doesn’t allow alpha maps. When you just pick what type of texture it is and don’t edit any other options, it configures everything for you. Manually change the compression type to a different one (either one that supports alpha, or one that says in the name ARGB and not just RGB).

Should work.

In the end I just used a separate 8bit texture. More files to manage, but it works.