Particle billboards scale according to distance to camera

I’m using the Shuriken particle system to display upward moving horizontal billboards. The problem I’m experiencing is that the billboards’ scale is based on the distance to the camera, rather than a CONSTANT scale in the scene meaning no matter where you view the particles from they will be the same size.

My current scene looks like this when the scale is correct:

However, when I move my camera closer both in scene-view and during gameplay the billboards rescale and become much smaller ending up looking like this:

!

I’ve placed a plane at the base of the particle system with the circle material to showcase the actual size that I intend the particles to be and as you can see, due to the camera being close to the billboards, they rescale.

If it is any help I’m also attaching my particle properties:
Properties

Is this intended or should I submit a bug fix request?

In the Renderer settings, increase MaxParticleSize. Anything about 3 or more is effectively “no limit.”

It starts at 0.5 and, if you look at the tooltip, that says billboards are clamped to take up at most 1/2 the screen.

I think it is intended to fix common a “particle in your face” problem. Without it, you might be walking through a scene with some glowy fire embers. You happen to have one move directly in front of you, where it swells and blocks your entire view.

Hi, all the answers online did not help me, but finally I found the solution:
The thing is: Min Particle Size and May Particle Size Settings will not affect your particles as desired as long as “Billboard Alignment” is set to “view”!

So if you want that your partciles in Unity keep a constant, absolute size (= size of particle in the world, not relative to the camera or viewport), set Billboard Alignment to “Facing”.

Also check all the aother parameters shown in the following screenshot, because they may interfere with your particle size if configured the wrong way!

Hope this helps!
Cheers,
Matt