Particle fog is visibly creating hard edges with geometry and terrain in scene


So I don’t know if it’s very clear in the picture, but i have tried creating a particle fog in URP, and it is very visibly cutting through and clipping with the ground and geometry in the scene. I heard about soft particles but couldn’t find out how to do it as I couldn’t find the setting allowing me to do it. I also tried creating a different camera rendering only the fog, but when running around the scene quickly found out that the approach there, with the extra fog layer on the main camera, would render the fog on top of everything. So I would be able to see it through everything in the scene. Is there any other approach to get it working, or somehow stop showing the clipping as much in unity URP?