Particle Mesh not showing up in scene view

I have a particle system set up that I want to use as an emitter for arrow projectiles. However, when I set my render mode to Mesh and set that to use my arrow mesh, nothing shows up. I have no clue what may be causing this.


Also here’s a screenshot of my emitter with nothing in it, and the arrow I want to use as mesh for my particles.

alt text

  1. Maybe the mesh native scale is too low, you may increase the start size accordingly.
  2. Render alignment (renderer module) should be local or world, not view.

For anyone else wondering about this, what solved it for me was:

MAKE SURE YOUR MESH ONLY HAS ONE MATERIAL :slight_smile:

or that you’ve specified all materials that you expect to appear.
in the renderer settings