Particle scales with camera distance

So I understand this is a question that is already answered, i’ve read the other threads about it.

Everyone says to stop the particle from scaling with the camera distance, you have to set the Min/Max particle size and the start size.

First of all, on my end, Start sizes changes nothing, I can set it to 0 or to 999999 and nothing changes.
My min Particle Size is set to 0.1 and my max particle size is set to 0.1
I’ve played around with these numbers but nothing affects the size over camera distance.

When I zoom out my camera, I don’t want the particles to scale with it.
FYI, I’ve only looked at it through the scene, by clicking on the particle system and watching the simulation.

Here’s the settings I currently have:


So I managed to get it to work. It really is the min/max and start size.
I read some other post that suggested a max particle size of 2 and it somehow fixed everything…

Unity is great… but things like that is just frustrating and making people lose their time.

Anyway, here’s the way I fixed it:


Start Size: 0.16

Min Particle Size: 0

Max Particle Size: 2

Hi, all the answers online did not help me, but finally I found the solution:
The thing is: Min Particle Size and Max Particle Size Settings will not affect your particles as desired as long as “Billboard Alignment” is set to “view”!

So if you want that your partciles in Unity keep a constant, absolute size (= size of particle in the world, not relative to the camera or viewport), set Billboard Alignment to “Facing”.

Also check all the other parameters shown in the following screenshot, because they may interfere with your particle size if configured the wrong way!

Hope this helps!

Thank you very much to have shared your problem (and your solution) ! You saved my morning…