Particle shader smoothening the texture

So, I have been trying to make a texture for a grass particle. I have created a texture in photoshop, saved it as a .png and with transparency, then I imported it enabled alpha is transparent. For some reason, my texture gets smoothed on the material (Not under the import settings) And there is a little dot on top of the material, I didn’t create that either.

Imported picture:


Result when on a particle:


Note: The texture is 16x16

Not sure if it helps but try changing Filter Mode to “Point” under import settings and also make sure your texture is power-of-two resolution (32x32, 256x128, or similar).