Particles don't appear in world space mode

I’m trying to add a particle system to GameObjects with script that simulate in world space, however the particles seem to be backwards, so appear invisible to the camera.

It works fine if I set the particle system to local space, however I need the particles to trail behind as the player moves through the world, so that’s not an option.

I’ve tried;

  • creating a prefab gameobject with the particle system and attaching it to the game object
  • creating an empty gameobject, adding a particle system component and attaching it
  • adding the particle system component directly to the GameObject

None of these work.

The really weird thing is that if I change a value within the inspector once the game is running, the particles seem to fix themselves and point in the right direction - however this isn’t an option as the player obviously can’t do that mid game. Changing a setting within code doesn’t work the same.

Attached are 2 images from the scene mode while the game is paused in the editor, the first no particles are visible. The second, I’ve rotated the camera and you can see the particles being emitted.

I hope I’ve explained that well enough for someone to help, because I’m completely stumped on how to make it work.

Changing Culling mode to “Always Simulate” fix the problem for me.
134585-338ea422-9692-467a-908e-f2599a082882png.jpg

Turns out that I needed to set particleSystem.enableEmission to true. For some reason this fixes the problem