Particles lag behind in world space?

Welp, the header says it all.

_
121891-4re3ge45r.gif

_
I can’t see my problem, the code is pretty simple actually.
_
(called in Update)
MouseParticles.transform.position = Camera.main.ScreenToWorldPoint(Input.mousePosition);
_
that’s basically it.

these are my settings on the particle system:
121890-d2e99e16067178c949abd563fdba4920.png

_
help’s appreciated,
thanks ^^

Hey! I recently ran into the same problem. The thing is that when you set the position of the particles using ScreenToWorldPoint, the Z position of the particle becomes equal to the Z position of the camera, because of this there is a sense of delay. I solved this by setting the position of the particle system without the Z coordinate.
Here is a sample code.