Particles that only show in light

I have gone through the forums several times and have tried all the suggestions but still can’t get my particles to show only within a light source.

According to this post and several like it:
http://forum.unity3d.com/threads/particle-and-light.25115/
all you need to do is change the particle shader to vertex lit blended.

However if you look at the scene, the particles show no matter if they are outside of the light or not.
I have tried every shader within unity and still no luck.

Is there something else or some other setting I am missing?

Cheers


Try using Transparent or Particle “VetexLit” shaders on your particle Materials.

You may not get the look you want right away by doing this, you may have to edit your particle Textures and play around with the shader settings.

use Particles/Multiply