[Patch 5.3.1p1] iOS: Enable bitcode support by default.

Hi, I recently updated Patch 5.3.1p1 and getting xCode build error related to enabled bitcode.

I would like to know if there’s a way to disable bitcode in settings or in postbuild.

Thank you.

I have the same problem. I updated Unity to 5.3.1p1 and reloaded the iOS Support and got this error in XCODE : (library does not contain bitcode.
I had no problem before with the v 5.3.1f1 anyone have a solution?

One way to disable bitcode is…

1. open xcode
2. In Build Settings
3. Find Enable Bitcode and set to No.

If you are not building directly from xcode and using automated build, you will need to disable bitcode using shell script. This is what I did.

sed -e 's/ENABLE_BITCODE = YES/ENABLE_BITCODE = NO/g' project.pbxproj > project.pbxproj-1
cp project.pbxproj-1 project.pbxproj
rm project.pbxproj-1

Hope it helped.

5.3.1p2 fixed it. :frowning:

It’s easy to disable bitcode with a PBXProject helper script, as documented here: https://support.unity3d.com/hc/en-us/articles/207942813-How-to-disable-Bitcode-support-