Phantom Joystick Input

I currently can’t play any Unity games because Unity thinks I constantly have a joystick pushed up and right. This persists through rebooting and every other thing I have tried. I use a wide variety of joystick compatible programs and have not found this behavior replicated in any other program. If I make my own program with the default joystick inputs removed, then I can finally control things.

Improvement Suggestion: On desktop executable Unity games, in the launcher, I should be able to go into the input section, select the joystick input parts of the grid, and clear them out completely. Right now, it will only allow me to replace them with other joystick input, which is useless when I don’t have a joystick.

But, first of all, please help me figure out how to get rid of this phantom joystick input so I can enjoy Unity.

I am on Windows 7 64 bit. In device manager, under sound, video, and game controllers, there are no game controllers listed. In Control Panel > Hardware and Sound > Devices and Printers there are no joysticks present, no input devices at all except my mouse and keyboard.

Input.GetJoystickNames.ToString() returns: “CompilerGenerated.__FPSInputControllerUpdate$cal lable0$1625”

This is the thread I made back in November about this issue:

I was having this issue as well. I couldn’t for the life of me figure out why I’m one of the few people having this issue.

What made the issue stand out to me, is that the problem went with me to different machines. So if I was using my work computer or my personal laptop, I would always get a phantom input pushing forward and to the left intermittently.

After a period of investigation, it was being caused by my 3DConnection Space Navigator 3D mouse. Unplugging the mouse isn’t good enough, you need to stop the application and services. I suspect it is acting as a joystick when working with Unity for some reason :frowning:

I was able to detect an input, but the name was blank.

foreach (var item in Input.GetJoystickNames())
  Debug.Log("Device: " + item);

Now to see if there is a way to exclude certain joysticks from common input… or change settings on the 3DConnection

i found that my madcatz rat x mouse was being detected as a joystick and panning my camera up all the time . i updated its firmware and disabled a strange device manager item related to it and all fixed u-p now
,for me all unity games were panning camera up , made a few games unplayable
i updated my mouses firmware and disabled a device manager item relating to it (rat x madcatz mouse) it no longer detected as a joystick then and seemed to fix all the games.

i was with the same problem and i fix it by actualizing the “vJoy” software that is windows default app that simulates a joystick.

I don’t know why but it was always sanding a virtual signal of a joystick pointing up and left.

-Here is where i download the actualization software " vJoy download | ".

–sorry for my bad english i’m not a native speaker.